Help - Search - Members - Calendar
Full Version: JMRI/Sprog 2
Model Rail Forum > The Engine Sheds - Community Forums > DCC
Hi all,
I've been busy updating some of my Zimo decoders with the MXULFA updater. Something seems strange. On some of the updates I get the full swiss mapping and all cv's in the list on my laptop. On others I either can't read them on the updater, the swiss mapping tab on DP is missing but the cv's are all there or there's a short list of cv's. For example I put a 9F on the programming track and updated the MX645 decoder. It reads back on DP as OK, but no swiss mapping tab and cv's only got to 365. I'm having similar troubles with others with MX648's. Also non sound decoders are giving me the nadgers. wink.gif

I have the latest software on the updater along with clean track, wheels and pickups.

Has anyone else had these problems and knows what's going on?
Stripping out the confusion from the title and paragraph above...

You updated the decoders with the MXULFA (which is what its for).

I think you're using the Sprog and JMRI to read the CV's.
There are several possibilities, and they may relate to version numbers of the updates....

In the JMRI list for Zimo decoders its broken down by firmware version number. Its always behind Zimo's actual updates, and never covers every Zimo release, because there are too many for people to keep track of (and the changes are often pretty trivial anyway). So, first thing is pick the nearest to your firmware release.

Next, there are preferences which you can set as to which tabs to display. That might be an issue (but probably not).

Other than that, a lot more details might be needed to work out what you're doing/seeing.

- Nigel
Thanks for the reply. Sorry for not making myself clear.
I've just checked again and this time I updated a western with an MX645 from V37 to 39. All went well and I could read back the Drive CV's with the updater. I used the Sprog2 and JMRI to read it and once again it was OK. Swiss Mapping came up as did all the CV's.

Then I put the 9F on the programming track and the updater wouldn't read the drive cv's and when I used DP2 and JMRI there was no Swiss mapping and the CV's finished at 365. I updated this decoder on the track three times yesterday in case something had corrupted something, but it's still the same.
I thought I'd give it another try and updated it for the fourth time and this time I could read the drive CV's on the updater afterwards. When I read it back with DP & JMRI there's still no Swiss mapping and no more than 365 Cv's.
It still drives all right I'm at a loss. This isn't the only loco that's doing this.
I've just updated another MX600 this time, to V39. The updater won't read it back and the CV's finish at 428.
I'm now wondering if the update file could have something wrong with it. What do you think?
If you're using the same JMRI decoder file, and its just the CV reading which is stopping at CV365 or CV428, then I think you can ignore JMRI/Sprog issues.

Sounds like something wrong with update process. Try getting new update files from Zimo's website and try again. If that fails, email Zimo's tech support.

As I understand the Zimo MXULF hardware, you should be able to manually read CVs from it (using the tools Zimo suggest), so use that to prove the high number CV's exist and can be written/read. Then your problem is totally in Zimo hardware/software/decoder/firmware, rather than introducing a third party (Sprog). There is meant to be support for the MXULF in JMRI, but I'd prove things work using the software Zimo reference on their website.

- Nigel
Thanks Nigel,
I'll have a look tomorrow and re-download the file from Zimo and see if that works. If not I'll contact them to see if they have any info.
Thanks for your help.
I thought I'd double check that I have in fact got the latest version of JMRI. I downloaded and installed what I thought would be v4.18. I got this message and picked merge, thinking that was the right thing to do:

Click to view attachment

It turns out that I'm still on v16. If I pick replace will that keep all the info' on there, loco's, settings etc?

I'm wondering if this has anything to do with it. I can't see that it would affect the updater reading back the drive cv's, but it could possibly explain why I don't see Swiss mapping and all cv's.
I don't know where JMRI keeps the "user" information on a Mac. I'd have thought it was somewhere other than in the application folder.

The settings you've saved should be in the user files (files for preferences, roster, roster entries, etc..) . Assuming they are somewhere else, I'd be replacing the files.

On the assumption you mean that "16" is "4.16" then that's only six months old, not likely to be the cause of no swiss mapping.

- Nigel
Yes sorry, I did mean 4.16.
I asked because when I've updated DP, up until now I've never seen that dialogue box. In the previous versions it seems to have just done it by itself. I think if I pick 'replace' it should keep all my files intact. What's the worst that can happen? I'll just have to spend days to read all the decoders again. smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2020 Invision Power Services, Inc.