Model Railway Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
642 Posts
Discussion Starter · #1 ·
Hi people I was wondering if any of you knowledgeable people could help me with a problem I have on a dapol class 66.

I bought a DRS liveried 66 and it has a wobble when running.

I contacted Dapol and they kindly sent me a set of wheels to replace the fault ones but I can't work out how to fit them. Has anyone else had this problem and been able to fit them to the loco themselves?

If you have could you please let me know and some instructions would be nice so that I can complete the fix myself
 

·
Registered
Joined
·
642 Posts
Discussion Starter · #2 ·
Well I spoke to Br lines today and they gave me some advice on what to do.

He confirmed that the crosshead screw at each end of the chassis drops the bogies from the drs locos. I did this and then looked at the back of the bgoes and there was a little gap to apply some pressure so that the side frames could be removed. I removed the frames successfully and then it was just a case of popping out the wheels in order and then replacing them.

The only fiddly bit was making sure that the driveshafts went back into the coupling to the motor and also to the connection on the bogie but after a trial and error session the loco has now been fixed and is working perfectly

Thanks BR lines and to everyone who has suggested something. Now to try and find a chip at a decent price to be able to fit in both of my DRS 66 locos.
 
1 - 2 of 2 Posts
Top