Model Railway Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have just tried updating my hornby elite firmware from version1.0 to 1.3. The procedure went as the instructions on the hornby website said but when i restarted the elite it still showed version 1.0. I tried the procedure again but my computer would not recognise the elite as new hardware so i could not proceed. I transferred the update file to another computer and the update seemed to go ok again but the elite was still on version 1.0. I have emailed hornby but still await a reply. Any advice would be greatly appreciated. Also is the update vital as i am prepared to carry on with version 1.0 if it only alters a few minor points of the elite.
 

·
Ian Wigglesworth
Joined
·
750 Posts
Vesion 1.2 has NMRA approval so I would install it if I were you, it does fix alot of the issues with the functions working correctly for each control knob. with some other fixes as well.

V1.3 adds a user selectable 'classic' mode which enables the Elite to work with the older original Hornby decoder, I wouldn't use that decoder anyway, and just leave the Elite in standard mode.

The newer Hornby decoder should now be fine though as they've now updated it at long last!

When updating make sure you select the correct com port that the Elite is connected to, also I've read it sometmes makes a difference if you connect it through a USB hub, so try and go directly into the PC's USB port and see if that will work.

If it still doesn't work send it back to Hornby who will update it for you, I believe you may need to be running windows XP as well, not sure if Hornby have done the latest drivers for Vista.

Cheers
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I plugged the elite straight into computer. I thought the stuff about com ports applied to non XP users. I am using windows XP. thanks for the info.
 

·
Ian Wigglesworth
Joined
·
750 Posts
When you download the whole driver/firmware update.
There is a utlility that once you've plugged your Elite into the PC, click on the utility and it will tell you which com port it's plugged into.

Make sure you select that com port when you begin the download!
Also make sure nothing can pull the mains cable out of the Elite while it's uploading, that may cause a bit of a nightmare!

Let us all know how you get on!

Cheers
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I tried again to update my elite and i got an "update fail" message and now my elite will not work at all apart from the power light flashing on and off. Called hornby and i have to email them again.
 

·
Ian Wigglesworth
Joined
·
750 Posts
You may need to try and reinstall it again.

It tells you this error can happen.

take a look here:-

http://www.hornby.com/digital/r8214firmware/

Near the bottom under trouble shooting it says that you may get this error, and to lower the com port speed and try again or even plug into a different USB port on the PC and try again.

Once you've done it and it works ok you will be wondering what the fuss was about.......Maybe
I'm struggling a bit because I never had an issue updating mine.

cheers
 

·
Just another modeller
Joined
·
9,983 Posts
QUOTE (wiggy25 @ 10 Jun 2008, 16:06) <{POST_SNAPBACK}>Vesion 1.2 has NMRA approval so I would install it if I were you, it does fix alot of the issues with the functions working correctly for each control knob. with some other fixes as well.

V1.3 adds a user selectable 'classic' mode which enables the Elite to work with the older original Hornby decoder, I wouldn't use that decoder anyway, and just leave the Elite in standard mode.

The newer Hornby decoder should now be fine though as they've now updated it at long last!

When updating make sure you select the correct com port that the Elite is connected to, also I've read it sometmes makes a difference if you connect it through a USB hub, so try and go directly into the PC's USB port and see if that will work.

If it still doesn't work send it back to Hornby who will update it for you, I believe you may need to be running windows XP as well, not sure if Hornby have done the latest drivers for Vista.

Cheers

***Software is better now but Elite still unfortunately seems to have some issues:

I just had a customer come in with an Elite V1.3 and when trying to use it with a popular brand of US locomotove the loco jackrabbits and runs roughly all the time whereas it runs smooth as silk with the NCE powerCab!

Richard
DCCconcepts
 

·
Premium Member
Joined
·
774 Posts
Funny, I was there when it all happened and I felt so sorry for this guy. Theres more to the story but Richard is being very PC. He had spent close to $800.00 on a new controller and sound loco. He is planning to get into model trains as he is close to retiring. You know the type of guy, easy going, always a smile on his face.

I think I will post a couple of test results I conducted with a oscilloscope at work on some controllers and leave it to the DCC professionals to comment.

m
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Tried several times to update my elite but got very fed up and took it back to the shop for a replacement. Felt a bit guilty as it wasnt the shops fault but they exchanged it for me. I am now staying with version 1.0 until any major problem becomes apparent, they alter the update procedure or there is a big incentive to upgrade. Now going to relax and do some model railway stuff, a hobby i started to reduce my stress level HA HA!!!
 
1 - 9 of 9 Posts
Top