Model Railway Forum banner

Firmware update problems

2132 Views 8 Replies 4 Participants Last post by  betamax
I have just tried updating my hornby elite firmware from version1.0 to 1.3. The procedure went as the instructions on the hornby website said but when i restarted the elite it still showed version 1.0. I tried the procedure again but my computer would not recognise the elite as new hardware so i could not proceed. I transferred the update file to another computer and the update seemed to go ok again but the elite was still on version 1.0. I have emailed hornby but still await a reply. Any advice would be greatly appreciated. Also is the update vital as i am prepared to carry on with version 1.0 if it only alters a few minor points of the elite.
1 - 3 of 9 Posts
Vesion 1.2 has NMRA approval so I would install it if I were you, it does fix alot of the issues with the functions working correctly for each control knob. with some other fixes as well.

V1.3 adds a user selectable 'classic' mode which enables the Elite to work with the older original Hornby decoder, I wouldn't use that decoder anyway, and just leave the Elite in standard mode.

The newer Hornby decoder should now be fine though as they've now updated it at long last!

When updating make sure you select the correct com port that the Elite is connected to, also I've read it sometmes makes a difference if you connect it through a USB hub, so try and go directly into the PC's USB port and see if that will work.

If it still doesn't work send it back to Hornby who will update it for you, I believe you may need to be running windows XP as well, not sure if Hornby have done the latest drivers for Vista.

When you download the whole driver/firmware update.
There is a utlility that once you've plugged your Elite into the PC, click on the utility and it will tell you which com port it's plugged into.

Make sure you select that com port when you begin the download!
Also make sure nothing can pull the mains cable out of the Elite while it's uploading, that may cause a bit of a nightmare!

Let us all know how you get on!

You may need to try and reinstall it again.

It tells you this error can happen.

take a look here:-

Near the bottom under trouble shooting it says that you may get this error, and to lower the com port speed and try again or even plug into a different USB port on the PC and try again.

Once you've done it and it works ok you will be wondering what the fuss was about.......Maybe
I'm struggling a bit because I never had an issue updating mine.

See less See more
1 - 3 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.