Model Railway Forum banner

Loco Programming Problem

1574 Views 6 Replies 4 Participants Last post by  dualfuel
Hi Guys,

Ive just had a strange occurrence with one of my Hornby DCC ready, Hornby chipped, A4s.

I was following the instructions in my Select controller manual to create a 'Consist' [double heading] between my A4 and a Hornby BoB Class.

However, when I dissolved the Consist both locos required their original addresses to be re-programmed, as they had both reverted to the default '03' setting [which doesn't normally happen].

The BoB was fine once programmed back to '09' - but for some reason the A4 always re-sets itself to the factory '03' setting, every time the controller is unplugged and then plugged in again.

It must be a decoder problem, as all my other locos re-programme fine [they all use the Hornby chip].

Is there anything I can do to reset the A4's decoder - or does it sound like a fault with the chip's memory?

See less See more
1 - 7 of 7 Posts
I think you're fast on track to becoming the most experienced "Select" user on the Forum, Edzmen, so you're blazing a trail for others to follow.

That's interesting news about creating a "Consist". I didn't realise that the Select got that ambitious. (and please can we not start a thread on "but it's not real consisting". For Select users with a limited stock of locos, I'm sure it does the job adequately).

I can't think why the A4 decoder would want to stick with an "03" address afterwards though.

This does sound like a decoder problem, but have you tried a factory reset on the select and then try reprogramming the decoder?

Only reason I suggest doing that is the problem appears to have occurred after you split the consist - which is a select function not the decoder.

I had to carry out a factory reset on my select after trying to program one of my NCE decoders, which didn't program and then left the select in a weird state where it would go through the motions but would not actually control anything.

I have not come across the problem of decoders returning to address '03' after consist handling..... yet!
Ive fixed it now - for some reason it didnt want to accept the '02' assignment, or '10'. I tried programming it as '22' and its memorised the allocation fine!
[weird though...]
See less See more
>'02' assignment, or '10'. I tried programming it as '22'
The only thing I can think of is a "bit stuck at 1". Underneath, the numbers are sent in hexadecimal. I wonder would it accept 16?

Don't feel you have to check this out - if your loco is working, leave it alone!

if you want a single digit address you could try 02, it might them work. As we understand it the Hornby select uses two digit addressing.............. so default decoder address is 03 and so on until you fill up all the slots available.
See less See more
I had a hornby decoder go back to '03' today also. I think what happened is I had a momentary short circuit with a derailed train throgh some points, and one loco on the system (class 47 - coded as '47') when I next tried to use it wouldn't move. I then guessed maybe it had gone back to '03' tried it and yes it had.

The only other loco on the 'live' track was my NCE decoder fitted battle of britain, which was already coded as '03'.

I think either the Select rebooted after the short and reprogrammed everything to be '03' (so in this case only the 47 changed numbers), or it is a problem caused by having the NCE decoder on the track when a short circuit occured.

I will try to experiment further to see if I can get it to happen again!
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.