Model Railway Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hiya All.
I have just upgraded my select to the hornby elite so I can use my laptop to control the system, But can anybody help, Me with the name of a softwere program or where I can get one from to put on laptop to do this.
Thanks Trev
 

·
DT
Joined
·
4,794 Posts
This is going to be fun.

Hornby have hardly come to terms with DCC, XpressNet and the NMRA. PC connectivity is perhaps going to be tricky.

Try JMRI software. This should work it the system is up for it. The tools are free and work fine with my Lenz equipment.
 

·
Premium Member
Joined
·
743 Posts
Good luck - hopefully everything will work well for you, but I fear another can of worms is approaching on platform 1! JMRI will be your best bet for now I would imagine. Thier expressnet stuff should work straight away but I haven't heard of anyone trying it out yet.
 

·
Premium Member
Joined
·
2,650 Posts
I tried JMRI however it seems the interface has a product specific menu and at this time the Hornby Elite does not feature in the menu. I kept getting time out messages in the display window. There is a general "direct" connection but not too sure what this is all about and when using it time out messages still appeared. If anybody does have any success communicating via a PC with the Elite using JMRI please report here.

Happy modelling
Gary
 

·
Ian Wigglesworth
Joined
·
750 Posts
Had the same issues as you Gary.

It may work if you connect the Lenz LI-USB interface up and connect that to the Elite through the XpressNet port and NOT the USB port.

There are other direct connections on the software like you have said, but it looks like these use the serial port, I dont have a serial to USB adapter cable so unable to try that.

It seems that the Hornby stuff does work with Lenz so I would guess this 'could' be a work around until there is a direct connection from the JMRI software via the USB port into the Elite.

Or I could just be talking rubbish, I have no idea, hopefully someone will put us right!

Ian
 

·
Ian Wigglesworth
Joined
·
750 Posts
Slightly off topic,

Would the PowerCab work as a slave if it was connected to the Elite??

They both use XpressNet, I think; I don't have the cable, well I do have a straight through cable with 4 connections in it that came with the PowerCab, but it looks like you need the CAT5 cable so don't want to try it.

As the PowerCab can be used as a slave on a PowerPro system thought it might work as a slave on the Elite?

What do you reckon??

Ian
 

·
Registered
Joined
·
825 Posts
QUOTE (wiggy25 @ 7 May 2007, 19:02) <{POST_SNAPBACK}>Slightly off topic,

Would the PowerCab work as a slave if it was connected to the Elite??

They both use XpressNet,
I would be VERY surprised if that is true. Anyone?

Andrew
 

·
Premium Member
Joined
·
743 Posts
NCE DO NOT use Xpressnet, they have thier own network system so the two will not work together.
 

·
Ian Wigglesworth
Joined
·
750 Posts
Well I tried it!

Connected the PowerCab to the Elite using the coil type conector cable that comes with the PowerCab for this very purpose.
Only has 4 wires connected so gave it a go.

Nope it didn't work


The PowerCab comes on and you can re-address the cab as per the instructions, but it just stays on that screen, you can't do anything else with it. Bit of a shame really.
Now is this because it just won't work, or could it be the flat type of cable being used?

I have a feeling the only type of slave you can connect to the Elite will be the Select or Select walkabout(are these 2 different things?)although Hornby don't claim anything else, so cant complain.
Shame that, if all the locos are using 4 digit addressing on the Elite how do you access them with a Select or do they all have to be on 2 digit addressing?

Ian

EDIT:- Thanks for that 80class, at least I now know!!
 

·
Premium Member
Joined
·
2,650 Posts
QUOTE It may work if you connect the Lenz LI-USB interface up and connect that to the Elite through the XpressNet port and NOT the USB port.

That thought had occured to me but it means making up an Xpressnet/USB adaptor. Given that the word is that the Elite has been benchtested with Railroad & Co software I wonder what the connection was? I haven't tried Railroad & Co software yet as I am not currently in a position to make the most of a 30 day free trial.

QUOTE if all the locos are using 4 digit addressing on the Elite how do you access them with a Select or do they all have to be on 2 digit addressing?

Again that thought had occured to me also!

Happy modelling
Gary
 

·
Ian Wigglesworth
Joined
·
750 Posts
Just pulled this from the Railroad & Co website:-

The following systems are not yet supported, approval for these systems is still pending or will come soon:
Hornby Elite: Hornby announced to open their computer interface to third party software developers. We plan to support this system as soon as it is completely available.

So we will have to wait and see!!

Ian
 

·
Ian Wigglesworth
Joined
·
750 Posts
Just an update on the PC software,
This is an Email from customer services at Hornby DCC.

When downloading/installing the ELITE update, the driver part of the update download is also used to allow the ELITE to talk to PC control software. We have designed the USB coms to work with "Train Controller" by RailRoad and co.. the protocols used are as per Lenz. In the Train Controller setup Digital System menu "Lenz Digital Plus /LI101F" works. We can't at this time guarantee the functionality of this set up as we are working with Railroad and Co on the interface etc.

At least they are working on it!

Ian
 

·
Ian Wigglesworth
Joined
·
750 Posts
Pulled this one back out!!

Has anybody tried this again, now the new firmware for the Elite is out and working with Train-Controller?

I have now sold my Elite as the function operation was driving me mad, far too long winded.

Anyway just curious to see if it now works with JMRI.

I think I tried the Lenz LI101f and LI USB when I had the Elite, the internal relay did click to switch to program track but then time out error on Panel Pro appeared.

I think I may also have changed the flow control and check buffer status, a combination of all of them to find one that seemed to work!

From what I was told the Hornby PC driver that is included with the firmware update wasn't talking to the software, would be interesting to see if it now works with the new firmware and is it a new driver version that is also downloaded?

Ian
 
1 - 13 of 13 Posts
Top